设为首页收藏本站

极客工坊

 找回密码
 注册

只需一步,快速开始

查看: 428|回复: 4

求助 arduino 4WD小车用L293D驱动板M1没反映

[复制链接]
发表于 2017-7-11 11:03:31 | 显示全部楼层 |阅读模式
请教各位,谁用过L293D驱动板啊,库文件AFMotor.h
非常奇怪,L293D驱动板可以控制4个直流电机,调试前面记得是可以的,让小车前进后退左右转都没有问题,是成功的;
后来写进程序后发现M1不转了,但程序检查没问题,又回去重新测试驱动板;
发现调试程序也真的不转了;
这到底是为什么啊,M2、3、4都没有任何问题,就是M1不管用了,而且我换了一块L293D同样的问题,应该是哪里调试得不对,求助大神!!!
QQ截图20170711105657.jpg

#include <Arduino.h>
#include <Wire.h>
#include <SoftwareSerial.h>
#include <AFMotor.h>
  AF_DCMotor zuoqian(1,MOTOR12_64KHZ);
  AF_DCMotor youqian(2,MOTOR12_64KHZ);
  AF_DCMotor youhou(3,MOTOR34_1KHZ);
  AF_DCMotor zuohou(4,MOTOR34_1KHZ);
void setup() {
  zuoqian.setSpeed(200);
  youqian.setSpeed(200);
  zuohou.setSpeed(200);
  youhou.setSpeed(200);
}

void loop() {
  zuoqian.run(FORWARD);
  youqian.run(FORWARD);
  zuohou.run(FORWARD);
  youhou.run(FORWARD);
  delay(3000);//直走3秒
  zuoqian.run(RELEASE);
  youqian.run(RELEASE);
  zuohou.run(RELEASE);
  youhou.run(RELEASE);
  delay(3000);//停止3秒
}
回复

使用道具 举报

 楼主| 发表于 2017-7-11 17:20:31 | 显示全部楼层
已经正常了  但不知道是哪里出的问题,程序在执行过程中并不够稳定,估计这也是L293D驱动模块的问题吧 有知道的可以留言哦
回复 支持 反对

使用道具 举报

发表于 2017-7-11 19:42:19 | 显示全部楼层
建议换成L298N或者其他电机驱动,我也试过,感觉是驱动电流不够造成的,跟程序关系不大。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-7-17 13:26:33 | 显示全部楼层
赤云 发表于 2017-7-11 19:42
建议换成L298N或者其他电机驱动,我也试过,感觉是驱动电流不够造成的,跟程序关系不大。

就是从L298N换过来的,总感觉L298N的两边电机同步性特别差...这些便宜的驱动都不怎么好用
回复 支持 反对

使用道具 举报

高级模式  
您需要登录后才可以回帖 登录 | 注册  

本版积分规则

Archiver|联系我们|极客工坊 ( 浙ICP备09023225号 )  

GMT+8, 2017-9-23 04:43 , Processed in 0.039831 second(s), 10 queries , File On.

Powered by Discuz! X3.3 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表