极客工坊

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 193|回复: 9

[未解决] MPU6050求助

[复制链接]
发表于 2017-12-7 11:14:46 来自手机 | 显示全部楼层 |阅读模式
ARDUIN烧好程序,连接6050数据正常,测试一会突然停止。无刷新,关闭电脑重新连接依然无数据。更换6050,更换数据线,跟换ARDUIN依然无数据接收。拔下6050 SCL时钟线,代码接收00000000。换板子烧代码不接6050接收都是00000000。插上马上暂停,拔下STL继续。问题出哪里了
回复

使用道具 举报

发表于 2017-12-7 13:21:35 | 显示全部楼层
先看看串口驱动还没,arduino坏没,都没坏再试试6050吧,你这说不上来哪里的问题
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-12-7 14:14:22 | 显示全部楼层
暂时解决,给两个6050回了火,把6050引脚加了热从新焊接下,其实已经焊接的很牢固,目的让芯片热下,把连接ARDUINO杜邦线的公头,挂上了一层焊锡。杜邦线的公头真的很坑,又短又小。经常虚接。

6050测试代码可以不接·模块。先烧录输出的全是00000.    之后解决杜邦线的问题,之后测试6050

我发现6050与ARDUINO地线虚连,就会无读数,没输出,串口0000都没有
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-12-7 14:19:40 | 显示全部楼层
这东西真的很皮实,电源接反了次ARDUINO灯都暗了,这糟心的6050竟然没烧
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-12-7 15:25:53 | 显示全部楼层
本帖最后由 zhuertie888 于 2017-12-8 23:19 编辑

这糟心的6050又犯病了,拔下6050数据刷新正常,00000000000,板子上TX灯亮,只要插上6050无数据刷新,卡住。。。。只要插上SCL线久卡住无输出,ARDUINO板子上的TX灯灭掉。。。两个6050同病状,没找到根本原因。感觉插上STL串口就停了。。。。测试别的代码串口输出HelloWorld实验,正常
回复 支持 反对

使用道具 举报

 楼主| 发表于 7 天前 | 显示全部楼层
又犯病了两个6050同症状,插上SCL时钟线,串口的TX灯灭掉。串口无输出。拔下TCL线输出00000000测试ARDUINO板子HelloWorld实验。串口正常。不知道碰哪里了过两天6050还会正常。
回复 支持 反对

使用道具 举报

 楼主| 发表于 6 天前 | 显示全部楼层
两个6050,又犯病了,给插针加热,芯片管脚加热,就好一段时间。。是芯片虚焊,还是6050的电容要坏。犯病的时候,提示,大概,TX RX,串口打不开,错误等内容。图片怎么传不上
回复 支持 反对

使用道具 举报

 楼主| 发表于 昨天 16:36 来自手机 | 显示全部楼层
initaliizng i2c devices......什么意思。通信出了什么问题
回复 支持 反对

使用道具 举报

 楼主| 发表于 10 小时前 来自手机 | 显示全部楼层
自己解决吧,又换了发了几4个6050,其中两个是i2c无数据通信的。mpu6050的产品仿制多,可以正常使用的不足一半
回复 支持 反对

使用道具 举报

发表于 9 小时前 | 显示全部楼层
看到楼主这么折腾,我也没遇到过这种问题,但我有个测试I2C device 总线地址的程序, 你可以运行看下能否显示I2C地址 来确定你的6050是不是出问题了。
I2C_ADDRESS_DETECTER.zip (793 Bytes, 下载次数: 0)
回复 支持 反对

使用道具 举报

高级模式  
您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|联系我们|极客工坊 ( 浙ICP备09023225号 )

GMT+8, 2017-12-15 21:50 , Processed in 0.043577 second(s), 6 queries , File On.

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表